Affected components
Updates

Write-up published

Read our write-up of this incident at https://assets.krystal.io/rfos/2025-10-30-network-issues.pdf

Resolved

All services are working as expected - an RFO will be published in due-course.

Thank you for your patience during this time.

Thu, Oct 30, 2025, 05:03 PM

Monitoring

We'll continue to monitor throughout the day but the earlier network action fully resolved the issue, and we've confirmed all systems have remained operational since them. We will provide a full RFO but from our investigations at this stage we believe these issues were caused by a bug in the routing software of one of our network devices and are planning in an upgrade to apply further fixes which will prevent any chance of this issue reoccurring.

Thu, Oct 30, 2025, 04:07 AM(12 hours earlier)

Monitoring

We've identified the network related issue, put a fix in place, and are currently monitoring.

Thu, Oct 30, 2025, 02:38 AM(1 hour earlier)

Investigating

We've investigating network issues affecting Katapult, currently the Katapult portal is not accessible and some other services are affected. We'll provide a further update on this as soon as possible and are investigating as a high priority.

Thu, Oct 30, 2025, 01:55 AM(43 minutes earlier)